*SH-04A [#aa885aff]
 Titleと異なってたりしますが、とりあえず参考までに。
 一応動いたけど、誰か元気のある人、綺麗に直して。

**ffmpeg最新版のメタデータオプションの変更 [#m15b9a78]
~
"-title"、"-author"、"-copyright"、"-comment"、"-genre"、"-album"が削除されて"-metadata x=y"の形に統合されました。ffmpegの最新版を使う場合は気をつけてください。~
http://lists.mplayerhq.hu/pipermail/ffmpeg-cvslog/2009-March/020804.html
~
***動画関連 [#g81c03ca]
-ffmpegは最新のものを使用してください

--[Item*]&br;
Title=H264 16:9設定 718x404/2Mbps/29.97/44100/128kbps&br; 
Command0=""<%AppPath%>\cores\ffmpeg" -threads 6 -y -i "<%InputFile%>" -title "<%Title%>" -timestamp "<%TimeStamp%>" -vcodec libx264 -coder 0 -vlevel 30 -bufsize 128 -g 250 -s 718x404 -r 30 -b 2048 -acodec libfaac -ac 2 -ar 44100 -ab 64 -f mp4 "<%OutputFile%>.mp4"" 

--[Item*]&br;
Title=H264 4:3設定 640×480/2Mbps/30/44100/128kbps&br;
Command0=""<%AppPath%>\cores\ffmpeg" -threads 6 -y -re -i  "<%InputFile%>" -title "<%Title%>" -timestamp "<%TimeStamp%>"  -mbd 2 -flags ildct -me_method full -vcodec libx264 -coder 0 -vlevel 30 -bufsize 128 -g 250 -s 640x480 -r 30 -b 2048 -acodec libfaac -ac 2 -ar 44100 -ab 64 -f mp4 "<%OutputFile%>.mp4""

--[Item*]&br;
Title=H264 汎用設定 720×480/2Mbps/30/44100/128kbps&br;
Command0=""<%AppPath%>\cores\ffmpeg" -threads 6 -y -re -i  "<%InputFile%>" -title "<%Title%>" -timestamp "<%TimeStamp%>"  -mbd 2 -flags ildct -me_method full -vcodec libx264 -coder 0 -vlevel 30 -bufsize 128 -g 250 -fixaspect -s 720x480 -r 30 -b 2048 -acodec libfaac -ac 2 -ar 44100 -ab 64 -f mp4 "<%OutputFile%>.mp4""

--[Item*]&br;
Title=xvid 16:9設定 718x404/2Mbps/29.97/44100/128kbps&br;
Command0=""<%AppPath%>\cores\ffmpeg" -threads 6 -y -re -i "<%InputFile%>" -timestamp "<%TimeStamp%>" -vcodec libxvid -mbd 2 -s 718x404 -deinterlace -r 30 -g 210 -sc_threshold -6000 -b 2000 -bt 5000 -qmin 3 -acodec libfaac -ac 2 -ar 48000 -ab 80 -vol 256 -title "<%Title%>" -author "" -copyright "" -comment "VGA(720x400) 30FPS" -f 3gp "<%OutputFile%>.3gp" 

--[Item*]&br;
Title=xvid 4:3設定 640x480/2Mbps/29.97/44100/128kbps&br; 
Command0=""<%AppPath%>\cores\ffmpeg" -threads 6 -y -re -i "<%InputFile%>" -timestamp "<%TimeStamp%>" -vcodec libxvid -mbd 2 -s 640x480 -deinterlace -r 30 -g 210 -sc_threshold -6000 -b 2000 -bt 5000 -qmin 3 -acodec libfaac -ac 2 -ar 48000 -ab 80 -vol 256 -title "<%Title%>" -author "" -copyright "" -comment "VGA(640x480) 30FPS" -f 3gp "<%OutputFile%>.3gp""

--[Item*]&br;
Title=xvid 汎用設定 640x480/2Mbps/29.97/44100/128kbps&br; 
Command0=""<%AppPath%>\cores\ffmpeg" -threads 6 -y -re -i "<%InputFile%>" -timestamp "<%TimeStamp%>" -vcodec libxvid -mbd 2 -fixaspect -s 720x480 -deinterlace -r 30 -g 210 -sc_threshold -6000 -b 2000 -bt 5000 -qmin 3 -acodec libfaac -ac 2 -ar 48000 -ab 80 -vol 256 -title "<%Title%>" -author "" -copyright "" -comment "VGA(640x480) 30FPS" -f 3gp "<%OutputFile%>.3gp""

***その他 [#ef8ccf14]
-だいたいSH-01A、SH906iあたりと同じ

***個人的暫定版 [#g81c03ca]
-ffmpegは最新にしてH.264設定を適当に。&br;
ビットレートや音質はお好みで変更してください。&br;
2MbpsでたぶんDVD画質くらいにはなるかと。&br;
真っ黒の画面で横線が入る不具合があるので、直せる方いたらお願いします。&br;
エンコードにマシンパワーと時間をかなり取られる可能性あり。&br;
非力なPCの方はお気をつけください。&br;
デュアルCPU搭載の方はthreadの値を2にしてみるとよいかと。


--[Info]&br;
Title=機種別設定:MP4ファイル, SH-04A向け設定&br;
TitleE=Model: MP4, for SH-04A&br;
Description=SH-04Aに向けた設定&br;
DescriptionE=Setting adjusted for DoCoMo/SH-04A.&br;

--[Item0]&br;
Title=H264 4:3/2Mbps/192kbps&br;
Command0=""<%AppPath%>\cores\ffmpeg" -threads 1 -y -i "<%InputFile%>" -timestamp "<%TimeStamp%>" -vcodec libx264 -coder 0 -vlevel 30 -bufsize 128 -g 250 -qmin 10 -s 640x480 -aspect 4:3 -partitions parti4x4+partp8x8 -re -b 2M -acodec libfaac -ac 2 -ar 44100 -ab 192k -f mp4 "<%OutputFile%>.mp4""

--[Item1]&br;
Title=H264 16:9/2Mbps/192kbps&br;
Command0=""<%AppPath%>\cores\ffmpeg" -threads 1 -y -i "<%InputFile%>" -timestamp "<%TimeStamp%>" -vcodec libx264 -coder 0 -vlevel 30 -bufsize 128 -g 250 -qmin 10 -s 704x396 -partitions parti4x4+partp8x8 -aspect 16:9 -re -b 2M -acodec libfaac -ac 2 -ar 44100 -ab 192k -f mp4 "<%OutputFile%>.mp4""



***コメント欄 [#l22b94c7]
#pcomment(below)

トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS